User avatar
torstein.honsi
Site Admin
Posts: 9210
Joined: Thu Nov 09, 2006 11:22 am
Location: Vik i Sogn, Norway

Why do my Flash movies appear above the Highslide popups?

Thu Jul 26, 2007 10:37 am

By default Flash movies show through other elements in the HTML page, even if the other elements are positioned above them. The solution is setting wmode to transparent in the Flash markup. This has to be done for both the object/param and embed tags.

Code: Select all

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"           
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0"
    width="300" height="250" id="Flash" align="">
    <param name="movie" value="Flash.swf" />
    <param name="quality" value="high"/>
    <param name="bgcolor" value="#FFFFFF" />     
    <param name="wmode" value="transparent" />

    <embed src="Flash.swf" quality="high" bgcolor="#FFFFFF"  width="300"
            height="250" name="Flash" align="" wmode="transparent"
            type="application/x-shockwave-flash"
            pluginspage="http://www.macromedia.com/go/getflashplayer">         
    </embed>
</object>
If this doesn't help, there might be other issues:

In some cases the embed/object code is used within a noscript tag, and a JavaScript function is called to add the Flash for JS enabled user agents. In that case you need to do wmode on the JS function as well. This is an example using the AC_FL_RunContent function. Notice how I added 'wmode','transparent' at the end of the comma separated parameters:

Code: Select all

AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','300','height','250','src','Flash','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','Flash','wmode','transparent' ); //end AC code

Return to “Highslide FAQ”