Anclote
Posts: 4
Joined: Wed Jul 01, 2015 9:32 pm

popup vs tab

Wed Jul 01, 2015 10:02 pm

I looked for this but couldn't find it, so I'll ask. I copied your code from Barebones samples, With Gallery, "Gallery example with white design". I checked that my installation has the .js and .css pages. In IE11 the images open in a new tab rather than as a popup. I've turned off popup blocker. I get the same result in Chrome 43. I'm using IIS (localhost) in Win7

Your example pages operate correctly when I view them in a browser. On my page the cursor (before clicking an image) doesn't turn into the '4 arrowed' cursor that I see browsing your examples.

What am I doing wrong?

Anclote

MisterNeutron
Posts: 430
Joined: Sun Aug 18, 2013 11:20 am

Re: popup vs tab

Wed Jul 01, 2015 10:40 pm

We're going to need a link to your site to debug this. What you're seeing usually happens when there's something wrong in the setup. But without being able to see your site, it's impossible to guess.

(Actually, when you hover on a thumbnail, you should be seeing the "magnifying glass" custom cursor, not the "four arrrow" move cursor.)

Anclote
Posts: 4
Joined: Wed Jul 01, 2015 9:32 pm

Re: popup vs tab

Thu Jul 02, 2015 5:10 pm

It's not on a server, I'm using localhost. When you say "setup" I'm not sure what you mean. I used the exact code that I copied from your example listed earlier with these exceptions:
1) the top level highslide directory is called "highslide4113", that's the version that I downloaded.
2) there are 3 .jpg files, called 1.jpg, 2.jpg, and 3.jpg
3) I don't have any thumbnail copies, so the divs look like this
<div class="highslide-gallery">
<a href="images/1.jpg" class="highslide" onclick="return hs.expand(this)">
<img src="images/1.jpg" alt="Highslide JS"
title="Click to enlarge" />
</a>
<div class="highslide-caption">
Caption for the first image. This caption can be styled using CSS.
</div>

the "highslide-with-gallery.js" and "highslide.css" came with the download and haven't been altered

MisterNeutron
Posts: 430
Joined: Sun Aug 18, 2013 11:20 am

Re: popup vs tab

Fri Jul 03, 2015 1:54 am

Without a link to your site, I can't tell whether the necessary resources are where they need to be, nor can I tell whether you've specified things like hs.graphicsDir correctly.

If you won't put up a test page on a server somewhere, there's not much anyone can do to help. As you can see, the demonstrations all work properly. So clearly you're doing something wrong. But I can't just guess what that might be. Not psychic.

Anclote
Posts: 4
Joined: Wed Jul 01, 2015 9:32 pm

Re: popup vs tab

Sat Jul 04, 2015 10:37 pm

I've uploaded everything to a semi-work URL, I'd appreciate it if you didn't publish the URL.

The test page is in the root (httpdocs) directory:
http://www.performance-dynamics-incorpo ... /test.html

highslide and the images directories are each one level down (httpdocs/highslide and httpdocs/images). All of the highslide files are those contained in the highslide-4.1.13.zip download and have not been altered.

You were right that I should be expecting to see a magnifying glass cursor, but I'm still just seeing the hand that indicates a link.

MisterNeutron
Posts: 430
Joined: Sun Aug 18, 2013 11:20 am

Re: popup vs tab

Sun Jul 05, 2015 1:31 am

The paths to the Highslide script and the CSS file are both incorrect - they both return a "404 - Not found."

I don't know where those files are located - they're not where you're telling me they are. This, for example, is not where the file is:

http://www.performance-dynamics-incorpo ... gallery.js

But that's where the page is looking for it.

Anclote
Posts: 4
Joined: Wed Jul 01, 2015 9:32 pm

Re: popup vs tab

Mon Jul 06, 2015 3:30 pm

Yes I forgot that the highslide files were 2 levels down, in /highslide/highslide/filename.

I fixed that and am at least getting different results. I still don't get the magnifying glass cursor, and when I click an image I see dots running around in a circle and a "LOADING" message but that's it.

My webpage is at the root level, my image files are 1 level down in the images directory. In the head area I have a javascript line that says
hs.graphicsDir = '/images';

Down in the body I have
<a href="/images/1.jpg" class="highslide" onclick="return hs.expand(this)">
<img src="/images/1.THUMB.jpg" alt="Highslide JS"
title="Click to enlarge" />
</a>

Is this a question of relativity? i.e. is highslide looking for /images/images/1.THUMB.jpg?

MisterNeutron
Posts: 430
Joined: Sun Aug 18, 2013 11:20 am

Re: popup vs tab

Mon Jul 06, 2015 5:22 pm

You've got hs.graphicsDir pointing to your images. It's supposed to be pointing to where the Highslide graphics are, not your images.

Code: Select all

hs.graphicsDir = 'highslide/highslide/graphics/';

Return to “Highslide Editor”