Digiconomist
Posts: 5
Joined: Fri Aug 25, 2017 10:25 am

embedding failure

Sun Apr 15, 2018 8:50 pm

Somewhere in the last 2 days the embedded highchart cloud charts on my website seemingly stopped functioning. Things have been working fine for the past year, so this was rather random. Specifically, it seems to affect my charts that are sourced from a Google spread sheet using this code:

Code: Select all

<iframe class="highcharts-iframe" src="https://cloud.highcharts.com/embed/ywoqita/" style="border: 0; width: 100%; height: 500px"></iframe>
I'm featuring them here: https://digiconomist.net/bitcoin-energy-consumption

What's visible now is actually the exported html, which isn't the perfect fix - but at least I'm showing something again. The charts also display fine viewing them directly, but the embed code is failing completely. How do I get this fixed?

Note: the last chart is running via the regular embed code, but the data is static (not from a google sheet)

daniel_s
Posts: 737
Joined: Fri Sep 01, 2017 11:01 am

Re: embedding failure

Tue Apr 17, 2018 1:44 pm

hi Digiconomist,

Thank you for your report. I have a few questions about your chart, and to fix your issues I need to have more specific informations about your chart.
1. Have you add some custom code on your charts configuration?
2. I need to ask you about the Google Spreadsheet key to your data. Could you provide me with it in some way?
3. The best way out of your problem for me would be to change your chart privileges to public, then I try to see your chart configuration "under the hood".

Best regards!
Daniel Studencki,
Highcharts Developer

Digiconomist
Posts: 5
Joined: Fri Aug 25, 2017 10:25 am

Re: embedding failure

Fri Apr 20, 2018 8:39 pm

Some of my charts do custom code, but even the ones that don't started facing the same problem at the same time eg https://cloud.highcharts.com/embed/HJ08fPI4z/

I've set this chart to public and sent a PM containing the spreadsheet key.

daniel_s
Posts: 737
Joined: Fri Sep 01, 2017 11:01 am

Re: embedding failure

Mon Apr 23, 2018 10:01 am

hi Digiconomist,

I see that now all your charts (attached in this topic) are working correctly now. Please let me know if you still have any problems with displaying your charts.

Best regards!
Daniel Studencki,
Highcharts Developer

Return to “Highcharts Cloud”