b53&i295j^
Posts: 2
Joined: Tue Sep 05, 2017 4:31 pm

Flash player does not work on your site !!!

Tue Sep 05, 2017 5:31 pm

On your main page http://highslide.com

1) I would first like to report an issue

When I click on the sample "DIsplay flash" or the sample "You tube w/fade effect"

a) When using Chrome browser
it says "You need to upgrade your flash player"
(see attached chrome.png)

b) When using Internet Explorer 11
it works, but with a warning
(see attached ie11.jpg)


Another user reported that it did not worked either with Microsoft Edge.

c) Only firefox works for me.


It seems that the ActionScript 3.0 is now "fully" deprecated by Chrome
https://developers.google.com/youtube/t ... player-api

And had been replaced with this
https://developers.google.com/youtube/i ... _reference

2) My current need is to simply embed a you tube video.
If you can provide a work around to the above problems, or a new sampls using iframe, that would be great

Many thanks.
Attachments
ie11.jpg
problem when using ie 11 (on windows 7)
ie11.jpg (38.49 KiB) Viewed 513 times
chrome.png
problem when using chrome
chrome.png (81.33 KiB) Viewed 513 times

MisterNeutron
Posts: 430
Joined: Sun Aug 18, 2013 11:20 am

Re: Flash player does not work on your site !!!

Tue Sep 05, 2017 5:56 pm

No need for Flash for YouTube. The barebones example for YouTube, modified for HTML5, and with some obsolete stuff removed:

Code: Select all

<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>Highslide JS</title>
<link rel="stylesheet" href="../highslide/highslide.css">
<script src="../highslide/highslide-full.js"></script>
<script>
hs.graphicsDir = '../highslide/graphics/';
hs.outlineType = 'rounded-white';
hs.outlineWhileAnimating = true;
</script>
</head>
<body>
<a href="https://www.youtube.com/embed/a0qMe7Z3EYg?rel=0&autoplay=1" 
		onclick="return hs.htmlExpand(this, {objectType: 'iframe', width: 480, height: 385, 
		allowSizeReduction: false, wrapperClassName: 'draggable-header no-footer', 
		preserveContent: false, objectLoadTime: 'after'})"
        class="highslide">Display YouTube movie</a>
</body>
</html>
This should work in all current browsers. Live demo: https://misterneutron.com/HSdemos/examples/youtube.html

Highslide JS is abandonware - no development, no support. So the broken demo on the front page will almost certainly never get fixed.

b53&i295j^
Posts: 2
Joined: Tue Sep 05, 2017 4:31 pm

Re: Flash player does not work on your site !!!

Tue Sep 05, 2017 9:06 pm

Thanks a lot, it works like a charm now. Very helpful !

Return to “Highslide JS Usage”