It is currently Wed Aug 23, 2017 2:37 am Advanced search

Disable “fill” attribute when using Styled CSS

Technical support for the Highcharts Stock package

Disable “fill” attribute when using Styled CSS

Postby paterfish » Thu Aug 10, 2017 11:02 am

I am using the latest version of highstock.js (v5.0.14) and my custom styles (using CSS) are being usurped by inline fill attributes.

For example, this CSS:

.highcharts-color-0 {
fill: #2b908f;
stroke: #2b908f;
}
Is being overwritten by this HTML attribute:

<path fill="rgba(124,181,236,0.75)" ... />
I am looking to disable the fill attribute. Using !important does not work.

This problem came after I upgraded to v5.0.14 (previously using v5.0.9 where the "fill" attribute was not in use)
paterfish
 
Posts: 2
Joined: Thu Aug 10, 2017 10:56 am

Re: Disable “fill” attribute when using Styled CSS

Postby kamil » Fri Aug 11, 2017 10:27 am

Hi paterfish,

I cannot reproduce this issue here (I don't see any difference): http://jsfiddle.net/kkulig/kwLg86e5/
Please provide me with some live working example (jsfiddle, file, url) that illustrates the problem.

Best regards!
Kamil Kulig
Highcharts Developer
kamil
 
Posts: 230
Joined: Tue May 30, 2017 11:12 am

Re: Disable “fill” attribute when using Styled CSS

Postby paterfish » Fri Aug 11, 2017 1:04 pm

I'm getting to the bottom of this now; thanks for the fiddle - it's helped.

I was totally thrown off by the upgrade from 5.0.9 to 5.0.14 changing all the styles. I then went back to 5.0.9 from the official site and it's still broken; but the version of 5.0.9 I have (definitely unedited) is working. So bizarre.

Anyway, all fixed now, I can see the issues. Thanks
paterfish
 
Posts: 2
Joined: Thu Aug 10, 2017 10:56 am


Return to Highstock Usage

Who is online

Users browsing this forum: No registered users and 0 guests