It is currently Fri Oct 31, 2014 10:13 am Advanced search

'hs' is undefined error

Technical support, bug reports, feature requests and more.

'hs' is undefined error

Postby Slider9999 » Thu Aug 19, 2010 1:23 am

Working on a site, working on setting up the 1st of several galleries. Noticed that when I load my page, images, etc. my pictures show as a red X. Also get a yellow error exclamation that shows the 'hs' is undefined error, related back to the hs.graphicsDir = '../highslide/graphics/';

Here is the other issue I noticed...when I put my cursor over one of the red "X's", and look at the URL being displayed in the task bar, my site name is missing from the URL. It shows: http://www.nwiis.com/images/etc..., but the correct path should be http://www.nwiis.com/RVFD/images/etc... My site name "RVFD" is not being shown, thus the red X's.

Do I need to set up a reference in one of the .js files to my web site? l looked at the code, plus the tutorial area, and could not find anything.

I'm new to Highslide so I appreciate any assistance. This is one good looking product!
Slider9999
 
Posts: 3
Joined: Thu Aug 19, 2010 1:03 am

Re: 'hs' is undefined error

Postby EarlyOut » Thu Aug 19, 2010 2:45 am

A link to your site would be a help (the links you've provided yield 404s).

It sounds like you simply have incorrect href's in your HTML code. Highslide doesn't "figure them out" - it just uses what you give it.

The hs.graphicsDir needs to be pointing to the directory that contains the Highslide graphics - it has nothing to do with where your image files are.
User avatar
EarlyOut
 
Posts: 1705
Joined: Sun Nov 11, 2007 11:22 pm
Location: Sector R

Re: 'hs' is undefined error

Postby Slider9999 » Thu Aug 19, 2010 2:50 am

Here is the link to the gallery under development.

http://www.nwiis.com/rvfd/PCF1.html
Slider9999
 
Posts: 3
Joined: Thu Aug 19, 2010 1:03 am

Re: 'hs' is undefined error

Postby EarlyOut » Thu Aug 19, 2010 3:06 am

The link to highslide-full.js is not correct - it gives "not found." Instead of ../highslide/highslide-full.js, It should be highslide/highslide-full.js

The link to highslide.css is not correct - it gives "not found." Instead of ../highslide/highslide.css, it should be highslide/highslide.css

hs.graphicsDir should be highslide/graphics/

The links to your image files are not correct - they give "not found." Instead of ../Images/Galleries/CommFund/Parade/4-1-Parade01.jpg, for example, it should be Images/Galleries/CommFund/Parade/4-1-Parade01.jpg

All of the links are relative to the location of the page itself, and your stuff is all at or below the level of your page. Putting ".." on the front end is telling the page to look one level above.
User avatar
EarlyOut
 
Posts: 1705
Joined: Sun Nov 11, 2007 11:22 pm
Location: Sector R

Re: 'hs' is undefined error

Postby Slider9999 » Thu Aug 19, 2010 3:18 am

Thanks, and that worked! I need to reformat the size of my pictures, but at least they are displaying properly now.

THANKS so much for the direction!
Slider9999
 
Posts: 3
Joined: Thu Aug 19, 2010 1:03 am


Return to Highslide JS Usage

Who is online

Users browsing this forum: No registered users and 7 guests