It is currently Tue Sep 23, 2014 12:19 pm Advanced search

Iframe issues opening html and php in safari and Opera

Technical support, bug reports, feature requests and more.

Iframe issues opening html and php in safari and Opera

Postby Sauko » Sat Mar 07, 2009 1:01 pm

Hi, i'm working with higslide in my site, and when I test on firefox it works fine, but Opera and safari are giving me diferent issues:

I'm using the Iframe function to load both external html and php files (stored in my server), opening from different image-links.

1. The html file contains an Iframe that contains the cooliris aplication for showing pictures from my flickr gallery. It works fine in firefox and Safari, but in Opera, when I close the popup, the popup closes, but leaves the content floating in the same place. I mean: I still can see the cooliris gallery although the popup is closed. ??? weird thing.

2. The php fle contains a contact form that i developed in php. Working fine in firefox and opera, but safari simply shows the code of the php file...

If I can fix these issues, everything will be working as expected. Incredible work, by the way, this Highslide Js. My congrats!
Sauko
 
Posts: 1
Joined: Sat Mar 07, 2009 12:51 pm

Re: Iframe issues opening html and php in safari and Opera

Postby torstein.honsi » Mon Mar 09, 2009 9:53 am

Thanks Sauko!

1) Try setting preserveContent to false. If that doesn't help, please provide a live test page for us to debug.

2) This sounds like a PHP problem rather than a Highslide problem. Try opening the contact form in a separate tag instead of in a Highslide iframe.
Torstein Hønsi
CTO, Founder
Highsoft Solutions
User avatar
torstein.honsi
Site Admin
 
Posts: 9198
Joined: Thu Nov 09, 2006 1:22 pm
Location: Vik i Sogn, Norway


Return to Highslide JS Usage

Who is online

Users browsing this forum: No registered users and 4 guests