It is currently Thu Apr 24, 2014 9:44 am Advanced search

alignTicks failure when zooming programmatically

Technical support, bug reports and more.

alignTicks failure when zooming programmatically

Postby cailie » Fri Feb 24, 2012 4:48 am

Every once in a while, our charts fail to align ticks. It happens unpredictably and rarely. But when it happens, it looks bad. Unfortunately and despite trying, I haven't been able to determine steps to reproduce the issue, and therefore cannot provide a demo.

We are currently using today's latest from github. But I remember seeing this problem before that.

I've searched for related problems on this forum and the issue tracker. Are there any known potential causes? Is anyone else out there having a similar problem?

I would love to be more specific... :(

Thanks


(Edit: Now that I know what's going on, I renamed the Subject from "sporadic/rare tick misalignment" to "alignTicks failure when zooming programmatically")
Attachments
alignTicks.PNG
alignTicks.PNG (29.1 KiB) Viewed 243 times
Last edited by cailie on Sun Mar 11, 2012 6:07 am, edited 1 time in total.
User avatar
cailie
 
Posts: 81
Joined: Sun Aug 28, 2011 9:43 am
Location: Vancouver, BC, Canada

Re: sporadic/rare tick misalignment

Postby Fusher » Mon Feb 27, 2012 12:28 pm

Try fixed min/maxPadding? Or can you just setup demo? We will try refresh several times ;)
Paweł Fus
Highcharts support team
Fusher
 
Posts: 5277
Joined: Mon Jan 30, 2012 12:16 pm

Re: sporadic/rare tick misalignment

Postby cailie » Tue Feb 28, 2012 12:40 am

Thanks Fusher :)
I'll try to set up a demo. With any luck the problem will be unreproducible.
-C
User avatar
cailie
 
Posts: 81
Joined: Sun Aug 28, 2011 9:43 am
Location: Vancouver, BC, Canada

Re: sporadic/rare tick misalignment

Postby cailie » Fri Mar 09, 2012 11:06 pm

Due to some further usage changes, this issue is no longer rare or sporadic for us. My excellent colleague has been able to reproduce this issue with an example.

The issue is logged here: https://github.com/highslide-software/h ... issues/822
User avatar
cailie
 
Posts: 81
Joined: Sun Aug 28, 2011 9:43 am
Location: Vancouver, BC, Canada


Return to Highcharts Usage

Who is online

Users browsing this forum: Google [Bot] and 9 guests